VS-LC102

For the browser, it is recommended to use IE9 or above.
Browsers, such as Chrome, Firefox, and Safari have stopped supporting NPAPI and cannot install the FireBreadthed VLC component. It is not recommended for use with VS-LC102.

Marketing